Problem with Oracle Server Discovery

Apr 1, 2011 at 3:19 PM


I was having issues using the x-manage Oracle MP in discovering Oracle File Systems for a particular Oracle database so I decided to disable the base discovery and remove all discovery data using a Powershell cmdlet.  However, since doing this I am now unable to discover any Oracle servers after the discovery has been re-enabled; I have even tried removing the Oracle MPs and going through the configuration process again but with the same results. I used the Remove-DisabledMonitoringObject cmdlet which removed the discovered data immediately.  Is there anything else that I need to do to kick start the discovery; when I first installed the MP the discovery worked without any problems.



May 2, 2011 at 2:35 AM

What is the interval listed on the object discovery in question? Any overrides in place?

May 2, 2011 at 11:22 AM


I think I have it discovering the objects in my Oracle environment successfully - I had to alter the XML source to get it to discover Oracle Processes though.  I also have to manually create a file on each Oracle server containg the encrypted Oracle Logon details - a rule should have created this file but it didn't trigger in my environment eventhough it is enabled and there are no overrides.  However, the reports do not seem to show any data and the performance counters do not show anything in the Operations Console Monitoring view.  Do you know anybody who might be able to assist me?

Thanks, Gordon.

May 22, 2011 at 1:05 PM


I am having the same issue. Did you find a soultion ?




Aug 15, 2011 at 5:18 PM



Is there any solution?



Sep 29, 2011 at 8:28 PM

how do I enable a log MP Oracle?
Is it possible?


Oct 24, 2011 at 11:08 AM



I just downloaded the updated version of the Management Pack. However, the discovery does'nt seem to work for my oracle servers running on solaris 10 servers. 

I have followed all instructions as per the Management Pack Guide and given the correct path and permissions. I have also enabled the discovery of servers and databases but nothing seems to discover the oracle servers.

Are there any troubleshooting steps which can help to find the cause for the servers not getting discovered ?

Any Help in this matter will be highly appreciated.


Thanks in Advance!