Problem with Oracle Discovery

Jun 14, 2011 at 5:27 PM

I've put the Oracle MP in to our test environment, some things have been discovered, but there are some issues...

When I check the Alerts, I get...

The Oracle Database Instance: <INSTANCE NAME>, of the server: <SERVER NAME>, has not been fully discovered.  This may indicate that the instance was down at the time of discovery, or monitoring authentication is configured improperly.   The instance will not be fully monitored until the SID can be discovered.

When using the Oracle Server Diagram View, and drilling down to the warning, it's fialing on the "Oracle Database Instance SID Discovered Check, and reports an Operational State of SIDNotDiscovered.

From reading previous discussions, I determined that the /tmp/manage-X/mxosqp had not been created on the Oracle server during discovery, and there was a c:\cmdstr.txt file on the Monitoring server with what looks to be the file creation commands. When using the contents of the c:\cmdstr.txt file to create the /tmp/manage-X/mxosqp, it failed with an error. Looking at the contents of the c:\cmdstr.txt, it appears there is a syntax error with the file...

mkdir /tmp/manage-X;echo <ENCRYPTED_STRING> /tmp/manage-X/mxosqp;;chmod 755 /tmp/manage-X;chmod 700 /tmp/manage-X/mxosqp

*notice the 2 semi-colons before the first chmod command

I ran this command, removing one of the additional semi-colons, which looks to have created the file OK. I can successfully connect to the database using the following command:

bash# sqlplus `cat /tmp/manage-X/mxosqp | openssl enc -d -base64`

SQL*Plus: Release Production on Tue Jun 14 16:34:29 2011

Copyright (c) 1982, 2009, Oracle.  All rights reserved.

Connected to:
Oracle Database 11g Enterprise Edition Release - 64bit Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options


...and so I don't think there's any authentication issues.


Any other advice would be greatly appreciated?





Jul 25, 2011 at 10:44 PM

Hi Steve,

This problem persists in our environment after modifying a few lines so I would suggest you try these:

Lines 281 and 1060
Where sqllogin=`cat /tmp/manage-X/mxosqp`;
Must be sqllogin=`cat /tmp/manage-X/mxosqp|openssl enc -d -base64`;

Lines 812 and 1123
If you have installed AIX or another OS where "hostname -f" is unsupported, you must replace with "hostname"


Aug 15, 2011 at 5:15 PM


I have the same problem.
the c:\cmdstr.txt file does not exist in the SCOM server and does not create anything in unix.


Sep 29, 2011 at 8:29 PM

how do I enable a log MP Oracle?
Is it possible?


Oct 14, 2011 at 9:57 PM

Has anyone been able to get this management pack to work after running into the error described by Steve?

Please let me know i am in the middle of deploying this management pack and ran into this problem, i am able to see performance data for the oracle process but none of the database related performance data is showing up.

Oct 15, 2011 at 1:41 AM

No David, not yet.

Oct 24, 2011 at 11:07 AM


I just downloaded the updated version of the Management Pack. However, the discovery does'nt seem to work for my oracle servers running on solaris 10 servers. 

I have followed all instructions as per the Management Pack Guide and given the correct path and permissions. I have also enabled the discovery of servers and databases but nothing seems to discover the oracle servers.

Are there any troubleshooting steps which can help to find the cause for the servers not getting discovered ?

Any Help in this matter will be highly appreciated.


Thanks in Advance!




Oct 24, 2011 at 10:28 PM

this problem with fully discovering the oracle databases renders this management pack as obsolete.

i am only able to see availability monitoring for the listener and the oracle process and a few performance counters in regards to the oracle process memory and cpu.

but all the wonderful monitors and rules described in the management pack documentation specifically for the database health do not work .

Oct 25, 2011 at 12:02 PM

Hi David, 


Could you please tell me if your oracle is installed on Solaris servers ? 

I seem to have a problem discovering them in the first place.

Any help will be highly appreciated !!


Thank You!

Oct 25, 2011 at 3:08 PM

oracle is installed on Red Hat Linux.

i am able to discover everything that has to do with the linux system resources (process cpu, memory, availability)

i am not able to discover the specific oracle database  (health, statistics, usage, etc)

Oct 26, 2011 at 9:32 AM

Hey David,

Thank You for the reply.

i have my oracle servers on solaris 10 boxes.

i am monitoring my OS using cross platform Management Pack in SCOM.

I have tried all the steps in the documentation but I can discover my oracle servers.

Enabled discovery, created proper run as accounts, associated them with the profile and so on. Given them rights as mentioned in the document.

Not sure where do I troubleshoot the problem from.